Table des matières
- 2026:
- 2025:
4 billet(s) pour septembre 2026
| Notes HTTP Strict Transport Security - HSTS | 2026/09/18 11:04 | Jean-Baptiste |
| Notes GNU Linux GPU carte graphiques | 2026/09/08 15:49 | Jean-Baptiste |
| Notes GNU Linux graphique | 2026/09/08 15:42 | Jean-Baptiste |
| Notes urlencoding - passer des mots de passe en HTTPS | 2026/09/03 17:58 | Jean-Baptiste |
Pb ssh
pseudo-terminal will not be allocated because stdin is not a terminal
https://github.com/cea-hpc/clustershell/issues/227
Pseudo-terminal will not be allocated because stdin is not a terminal.
$ ssh serveur -- sudo ls /root sudo: sorry, you must have a tty to run sudo
$ ssh -t serveur -- sudo ls /root config.snmp.tar.gz install.log install.log.syslog main.cf sources tar_files Connection to server.acme.fr closed.
Voir aussi ssh -tt
Cloud OpenStack DevStack
OpenStack
Voir aussi :
- OpenNebula
- CloudStack
Autre
- Certified OpenStack Administrator Exam
Pré requis :
- 8Go RAM
- 2 Cores
- 1 NIC
- Ubuntu LTS
Voir :
/etc/environment
# http_proxy=http://192.168.56.1:3128 # https_proxy=http://192.168.56.1:3128 ALL_PROXY=http://192.168.56.1:3128 NO_PROXY=localhost,127.0.0.0/8,localaddress,.localdomain.com,192.168.56.0/24,::1
apt-get update apt-get upgrade
export ALL_PROXY=http://127.0.0.1:3128 export NO_PROXY=localhost,127.0.0.1,192.168.56.11 git config --global http.proxy http://127.0.0.1:3128 git clone https://git.openstack.org/openstack-dev/devstack
Notes en vrac
sudo apt-get install \ git \ python-cliff \ python-dev \ python-pip \ ebtables \ bridge-utils \ thin-provisioning-tools \ qemu sudo pip install --upgrade pip #sudo pip install -U os-testr git config --global http.proxy http://127.0.0.1:3128 git clone https://git.openstack.org/openstack-dev/devstack master cd master cp samples/local.conf .
local.conf
ADMIN_PASSWORD=secret DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD # hostname -I HOST_IP=192.168.56.11 #IPV4_ADDRS_SAFE_TO_USE=192.168.56.0/24 #FLOATING_RANGE=192.168.56.0/24 VERBOSE=True #RECLONE=yes #PIP_UPGRADE=True #IP_VERSION=4+6 IP_VERSION=4 DEFAULT_INSTANCE_TYPE=m1.tiny
stackrc
HOST_IP=${HOST_IP:-172.16.1.5} GIT_BASE=${GIT_BASE:-https://git.openstack.org}
sudo master/tools/create-stack-user.sh sudo chown -R stack:stack master sudo ufw disable sudo su stack master/stack.sh
/etc/nova/nova.conf
compute_driver = libvirt.LibvirtDriver [libvirt] virt_type = kvm cpu_mode = custom cpu_model = Nehalem
Désinstall & réinstall
./unstack.sh ./clean.sh ./stack.sh sudo reboot
/usr/bin/nova-compute --debug --config-file /etc/nova/nova.conf --log-file /var/log/nova/nova-compute.log tail -n 3 /var/log/nova/nova-compute.log systemctl restart openstack-nova-compute.service
https://docs.openstack.org/nova/latest/user/support-matrix.html
journalctl --unit 'devstack@*'
Pb SSH over VPN - Connexion KO après expecting SSH2_MSG_KEX_ECDH_REPLY
Connexion SSH KO après debug1: expecting SSH2_MSG_KEX_ECDH_REPLY \ Alors que flux réseaux OK.
ip r get 192.168.255.118
192.168.255.118 dev tun0 src 192.168.100.4 uid 0
cache
Solution : Réduire la MTU
ip l set mtu 1200 dev tun0
Pb SSH long lent
Voir aussi :
Sources :
Pb
ssh -vvv plop
debug1: Requesting no-more-sessions@openssh.com debug1: Entering interactive session.
[ TRES LENT ICI ]
Autre commande longue. su sur le serveur et connecté en root
su - user -c date
Solution
# systemctl daemon-reexec
systemctl restart dbus
systemctl restart systemd-logind
Autres solutions pour autres Pb
DNS, Kerberos/GSSAPI
Coté client ~/.ssh/config
Host *
GSSAPIAuthentication no
GSSAPIKeyExchange no
Coté serveur /etc/ssh/sshd_config
UseDNS no
Pb ssh forward - Connection refused
Voir aussi : /proc/sys/net/ipv4/ip_unprivileged_port_start
ssh -R1443:web-app:443 vm_test
$ curl https://web-app:1443 curl: (7) Failed to connect to web-app port 1443: Connection refused
ou
$ curl https://web-app:1443 curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to web-app:1443
Erreur retournée sur la console du tunnel ssh
connect to web-app port 443 failed: Permission denied
Solution
Le problème vient de SELinux
Sur la machine qui lance la commande ssh
sudo setsebool -P nis_enabled 1
